Tutorial - Revit® Integrator For Revit Versions Prior to 2024

Nota: This tutorial is for Revit versions prior to 2024. If you are using Revit 2024, see Tutorial - Revit® Integrator For Revit 2024.

Este tutorial describe cómo puede usar Revit Integrator para crear un diagrama-unifilar de EasyPower a partir de un proyecto de Revit y compartir datos entre los dos programas. Para realizar los pasos de este tutorial, debe haber instalado una versión compatible de Revit y también haber instalado el complemento Revit Integrator. Ver Para instalar el Complemento EasyPower a Revit para más información.

Para crear un diagrama-unifilar desde el Proyecto Revit

  1. En Autodesk® Revit®, abre el Muestra de proyecto de sistemas.
  2. The Revit Sample Systems Project icon is shown.

  3. Haga clic en la pestaña Comlementos y luego haga clic en Abre en EasyPower.
  4. On the Add-Ins tab, the Open in EasyPower button is highlighted.

  5. El cuadro de diálogo Importar model Revit se abre. El archivo de entrada ya está seleccionado, por lo que no es necesario seleccionar un archivo diferente.
  6. The Import Revit Model dialog box is shown. The Input File tab is selected. The import file name is shown.

  7. Haga clic en Asignación. Para este ejemplo, utilizaremos el Asignaciones predeterminadas de Revit , pero observe que también puede crear asignaciones personalizadas de Revit y crear nuevos archivos de configuración aquí. Esto le da un control adicional sobre cómo se importan los datos y le permite crear archivos de configuración que puede reutilizar en futuras importaciones.
  8. On the Import Revit Model dialog box, the Mapping tab is selected, and the Default Revit mappings option is selected.

  9. Hacer clic en Destino de Diagrama-unifilar. Para este ejemplo, seleccionaremos Crear diagrama-unifilar nuevo, pero observe que también puede combinar los datos de importación con un diagrama-unifilar actual.
  10. In the Import Revit Model dialog box, the One-line Target tab is selected. The Create new one-line option is selected.

  11. Haga clic en Resumen para revisar las configuraciones de importación y luego haga clic en Importar.
  12. In the Import Revit Model dialog box, the Summary tab is selected.

  13. EasyPower muestra el diagrama-unifilar que creó a partir del proyecto Revit. El programa también crea un informe que describe los problemas que se descubrió. Para ver el informe, haga clic en Ventana > Importar Informe de Resultados.
  14. The imported one-line is shown in EasyPower.

    The Import Error report is shown.

Ver los datos importados de Revit

Para cada elemento en el diagrama-unifilar, puede ver los datos que se importó al seleccionar Datos recogidos en el cuadro de diálogo de datos del equipo y luego haga clic en la pestaña Datos recogidos.

The number 1 is shown next to the Collected Data link in the Two Winding Transformer Data dialog box. The number 2 is shown next to the Collected Data tab that displays the imported data.

Para actualizar el archivo de EasyPower con los cambios de Revit

A medida que los datos cambian en el proyecto de Revit, puede enviar los cambios a EasyPower para actualizar su modelo del diagrama-unifilar. Tiene control sobre qué cambios se combinan en EasyPower.

  1. Asegúrese que el archivo rme_basic_sample_project.dez todavía está abierto en EasyPower. Solo puede combinar datos a un archivo de diagrama-unifilar abierto.
  2. Seleccione Archivo > Importar > Importar desde Revit® Integrator.
  3. Con el archivo de entrada seleccionado, haga clic en Navegue, y luego navegue a la carpeta C:\Users\{username}\Documents\EasyPower 26.0\Onelines\Samples\Revit y seleccionar el archivo Example_rme_basic_sample_project-Rev1.rvt2ezp. Este archivo incluye los cambios hechos al proyecto de Revit. Haga clic en Abre.

    Nota: NO seleccione el archivo en la carpeta Temp que se creó anteriormente en este tutorial. Debe navegar para seleccionar el archivo especificado, que representa las revisiones del modelo de Revit.

  4. The sample project file is shown as selected in the Open file dialog.

  5. En el cuadro de diálogo Importar modelo de Revit, con Archivo de entrada seleccionado, observe que se muestra el archivo que seleccionó en el paso 3.
  6. In the Import Revit Model dialog box, the Input File tab is shown, and the import file is shown.

  7. Haga clic en Destino del diagrama-unifilar y luego seleccione Combinar con diagrama-unifilar actual. Tenga en cuenta que puede seleccionar utilizar los valores de Revit o EasyPower cuando los resultados son diferentes. Esto solo establece los valores predeterminados—aún puede hacer cambios antes de la combinación real. Por ahora, seleccionaremos Utilice valor de Revit
  8. In the Import Revit Model dialog box, the One-line Target tab is shown. The Merge with current one-line option is selected.

  9. Hacer clic Resumen para revisar la configuración, y luego haga clic en Importar. Se muestra el cuadro de diálogo Combinar proyecto
  10. The Project Merge dialog box is shown.

    Tenga en cuenta que puede haber varias pestañas en la parte superior del diálogo para que los equipos se actualicen, agreguen o eliminen. En este ejemplo, solo hay una: Equipos para actualizar en EasyPower. Cuando combina sus propios archivos, asegúrese de observar las pestañas adicionales.

  11. En la pestaña Equipo para Actualizar en EasyPower, seleccione el primer elemento de equipo, panel LP-1B. Tenga en cuenta que la columna EasyPower muestra una clasificación de barra de 100, pero la columna Revit, que está resaltada en verde, muestra 250 y la columna Utiliza muestra 250 (que es el valor de Revit). Puede seleccionar el valor que desea al hacer clic en él.
  12. The Equipment LP-18 is selected and the Revit column for Bus Rating displays 250.

    Si selecciona la casilla de verificación Resuelto, utilizará automáticamente el valor predeterminado que especificó en el Paso 5.

    The Use column displays 250, which matches the Revit value.

  13. En algunos casos, es posible que no desee aceptar todos los cambios de combinación. Para cualquier cambio que no desee combinar asegúrese de que la casilla de verificación Aceptar no está seleccionada.

  14. The first three equipment items show the Accept checkbox selected; for the last item, the checkbox is clear.

    Sin embargo, para este tutorial, seguir adelante y acepte los cambios.

    All of the Accept checkboxes are shown as selected.

  15. Puede continuar seleccionando los valores que desea combinar en el diagrama-unifilar de EasyPower. Cuando termina, haga clic en Combinar, y luego haga clic en Yes. La combinación ignora cualquier elemento en el que no haga clic en la casilla de verificación Aceptar. El programa muestra un informe para informarle de los cambios.
  16. The Import Error Report is shown.

Realiza Diseño y Análisis en EasyPower

Después de crear su diagrama-unifilar de EasyPower a partir de los datos de Revit, puede realizar cambios de diseño y análisis en el diagrama-unifilar. Esto incluye realizar un diseño automatizado, realizar un análisis de cortocircuito y análisis de arco eléctrico, y calcular la caída de tensión en el flujo de potencia. Para información sobre estas características, por favor refiérase a los tutoriales adicionales. Tenga en cuenta que es posible que deba agregar componentes adicionales (como una fuente de potencia de servicio-eléctrico) y escribir datos adicionales (como impedancias del transformador) para poder realizar el análisis.

Para el ejemplo, agregue un servicio-eléctrico, escriba las impedancias del transformador y realice Diseño automatizado en todo el sistema. Asegúrese que puede abrir el modo de análisis Cortocircuito, y luego provoque fallas en todas las barras.

Exportar a Revit

Una vez que haya realizado cambios en su diagrama-unifilar de EasyPower, puede exportar los cambios a un archivo que puede importar a Revit. Para crear el archivo de exportación en EasyPower:

  1. En el modo Editar Base de datos, haga clic en Archivo > Exportar > Exportar a Revit® Integrator.
  2. En el cuadro de diálogo Configura exportación Revit, seleccione los elementos que desea exportar. Luego haga clic en OK.
  3. Nota: Caída de tensión flujo de potencia solo está disponible si ejecute un análisis de flujo de potencia y realice cálculos de caída de tensión.

    The Configure Revit Export dialog box is shown.

  4. El programa le pide un nombre de archivo y ubicación. Puede usar cualquier nombre que desea, pero el archivo debe tener una extensión .ezp2rvt. Para evitar conflictos con otros archivos, pongamos el archivo en el Escritorio. Tome nota de la ubicación del archivo, y luego haga clic en Guardar.
  5. In the Save As dialog box, a sample export file is shown.

Importar a Revit

Ahora puede importar el archivo que se creó en EasyPower en Revit. Tenga en cuenta que puede configurar si la información se importa y también controlar qué parámetros se utilizan haciendo clic en el botón Configurar importación antes de importar. Para este ejemplo, usaremos las selecciones predeterminadas.

On the Add-Ins tab, the Configure Import button is highlighted.

The Configure EasyPower Import dialog box is shown, with all options selected.

Para importar el archivo:

  1. En Revit, en la pestaña Complementos, haga clic en Importar .
  2. On the Add-Ins tab, the Import button is highlighted.

  3. Seleccione el archivo que se creó en el paso anterior y luego haga clic en Abra.
  4. In the Open EasyPower Export Data dialog box, the sample file is selected.

  5. Seleccione panel de distribución LP-1B en el dibujo y luego mire al panel Propiedades a la izquierda. Observe todos los valores de EasyPower bajo el encabezado Ingeniería eléctrica. (Su información puede aparecer diferente a la que se muestra, según lo que haya cambiado en EasyPower.)
  6. The Properties pane in Revit is shown. Under Electrical Engineering, EasyPower values are displayed.

Para enlazar un DXF a Revit

EasyPower puede crear archivos DXF que puede enlazar a su proyecto de Revit. Hemos creado un archivo DXF de ejemplo para demostrar esta característica.

  1. En Revit, desde el menú Vista, haga clic en Vista de diseño.

    On the View menu, the Drafting View button is highlighted.

  2. Proporcione un nombre de dibujo y establezca un valor de escala, y luego haga clic en OK.

    In the New Drawing View dialog box, the name Drawing 1 has been entered. The OK button is active.

  3. On the Insert menu, click Link CAD.

    On the Insert menu, the Link CAD button is highlighted.

  4. Ya hemos creado un archivo de dibujo para que lo utilice en el ejemplo. En el cuadro de diálogo Enlace formatos CAD, navegue a los ejemplos de Revit ubicados en C:\Users\{username}\Documents\EasyPower 26.0\Onelines\Samples\Revit, cambie Archivos de tipo a Archivos DXF (*.dxf), y seleccione el archivo Example_rme_basic_sample_project.dxf, y luego haga clic en Abra.

    In the Link CAD Formats dialog box, the Files of type has been set to DXF Files.

  5. Se muestra el diagrama-unifilar en Revit. Puede ampliar para ver los detalles del diagrama-unifilar.

    The one-line drawing in Revit is shown.

Conclusión

Esto ha sido un breve resumen de la característica de Revit Integrator de EasyPower. Los tópicos que se encuentran de Ayuda en EasyPower cubren esta y otras funciones con mayor profundidad. Para abrir Ayuda, haga clic  Ayuda en la esquina superior derecha de la ventana de EasyPower o presione F1.

Más Información